Adobe Photoshop CS5.5 was released about a year ago. CS6 is out now, but with 5.5 barely being a year old, anyone who bought it could safely expect Adobe to keep it up to date for a while, right? Not so much.

Adobe found a vulnerability that would allow a malicious .TIFF file opened in PS5.5 to allow a hacker to take over your system. OK, no problem, here's the security update. Except the "update" is Photoshop CS6. For everyone else, Adobe suggests they follow "security best practices and exercise caution when opening files from unknown or untrusted sources."

You know what's included in "best practices," Adobe? Updating to the latest versions of your software's security patches. Usually, mind you, your software, specifically, since everything you make is a magnet for hackers and vulnerabilities. Ugh. [Adobe via Ycombinator]